CHAPTER 1
AN INTRODUCTION TO STAROFFICE WRITER
1.1

An Introduction to StarOffice

StarOffice is an application that is designed to work on different
operating systems. StarOffice is a full-featured office productivity suite
with powerful standalone applications that can also open, edit, and
save Microsoft Office documents. Whether you are writing a letter,
performing complex calculations, creating a presentation, or creating
a database, you’ll find that StarOffice meets your needs.
StarOffice consists of several applications. These applications
are grouped together into an integrated environment in which one can
do several things. Listed below are some of the StarOffice functions,
Create text document using StarOffice Writer
Create spreadsheets using StarOffice Calc
Create presentations using StarOffice lmpress
Draw using StarOffice Draw
Create a database using StarOffice Base
To Start StarOffice,
1. On the taskbar, click the Start button.
2. Choose All Programs → StarOffice 8 folder.
3. Click the StarOffice program that you want to start.
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Fig 1.1 Selecting StarOffice Writer from Start Menu
StarOffice Writer is a word processor. The term word processing
refers to the activity carried out using a computer and suitable software
to create, view, edit, manipulate, transmit, store, retrieve and print
documents. A document may contain text, tables, graphs, charts,
equations, pictures and drawings.
Some of the other commercially available word processing
packages are MS Word, Lotus AmiPro, Word Perfect, Word Star and
Word Pro.
1.2

Creating a New Document Using StarOffice Writer
The StarOffice Writer is opened as shown in figure 1.1.

The File → New → Text Document command can then be
used to open a new document.
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A blank document appears as shown in figure 1.2

Fig 1.2 StarOffice Writer window
Most of the elements of this window are similar to the Windows
applications environment studied earlier.
1.3

Entering Text in the Document

Once a new document is opened, the text of the document can
be typed in big blank area of the screen. To create a document the
user can start typing straight away. As the characters are typed they
appear on the screen and the flashing vertical bar called the insertion
point, moves to the right. This insertion point always indicates where
the new text will appear. When the text being typed reaches the end of
the line, StarOffice Writer will automatically wrap the text to the next
line. The Enter key must not be pressed at the end of the each line.
The Enter key should be pressed only at the end of a paragraph or
when a blank line is to be inserted. When a page is filled up, StarOffice
Writer automatically creates a new page.
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1.4

Saving, Closing and Opening Documents

1.4.1 Saving a Document
The first time the document is saved, StarOffice Writer prompts
for a name. Naming the file enables the user to find and open that file
again. One can select the drive and folder where the file will be stored.
To save a document for a first time following steps are used:
1. File → Save command is selected or
icon is clicked. A
Save As dialog box as shown in the figure 1.3 appears on the
screen.
2. To select a drive, up one level icon
is clicked, then a list of
drives will be displayed. On the list of drives, a double click is
made on the required drive. Now a list of folders available on
that drive is displayed.
3. A double click is made on the required folder and the file name
is given in the File name list box.
4. Choose the required document type from the Save as type list
box and click on the Save button to save the document in that
type. The document is now saved and a file name appears in
the title bar.
Once a file is saved under a name, to save it again the name
need not be entered again. The file can be saved simply by selecting
the File → Save command or by clicking the Save button. Ctrl + S is
the keyboard shortcut for saving the document.
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Fig 1.3 Save As dialog box
1.4.2 Closing a Document
After a document is saved, it is not closed. It remains open so
that the user can continue working. When the work is finished, the user
should save and close the document. After saving, the document can
be closed using the File → Close command.
1.4.3 Opening a Document
To reopen a document that has been saved and closed, the
File → Open command can be used. A dialog box, very similar to the
Save As dialog box, appears, as shown in figure 1.4.
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Fig 1.4 The Open dialog box
The name of the file to be opened can be chosen from the list,
which is displayed.
File

An alternate method of opening files is to click on the Open
icon.

1.4.4 Working with Multiple Documents
While working with StarOffice Writer, it is possible to have several
documents open at the same time. This can be done by opening the
documents one after the other. Once the documents are open, you
can switch between them in the following two ways.
1. Click on the Window menu option and select the file from the
list of documents displayed.
2. Click on the document button visible on the taskbar.
6

These documents can be closed one by one by using the
File → Close command.
1.5

Moving Around the Document

To move the insertion point to anywhere in the document either
the mouse or the keyboard can be used. The thick horizontal line in the
page area is called the end-of-document marker. The insertion point
cannot be beyond this line.
To move the insertion point with the mouse, the mouse pointer
is moved to the required spot and the mouse button is clicked. The
insertion point jumps to that spot. It is to note that mouse pointer is
different from the insertion point.
To move the insertion point with the keyboard the arrow keys
and other key combination can be used. Table 1.1 lists the common
movement keys. If the key combination is joined with a plus sign, the
first key must be pressed and held down and the second key is to be
pressed.
Table 1.1 Keyboard movement keys
Press

To move

LEFT ARROW
RIGHT ARROW
CTRL+LEFT ARROW
CTRL+RIGHT ARROW
SHIFT+TAB
TAB
UP ARROW
DOWN ARROW
END
HOME
PAGE UP
PAGE DOWN
CTRL+END
CTRL+HOME

One character to the left
One character to the right
One word to the left
One word to the right
One cell to the left (in a table)
One cell to the right (in a table)
Up one line
Down one line
To the end of a line
To the beginning of a line
Up one screen (scrolling)
Down one screen (scrolling)
To the end of a document
To the beginning of a document
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___________________________________________________________________
Learn by solving
1.

Enter the following text.
According to legend, the ancient Olympic Games were founded
by Heracles. Yet the first Olympic Games for which we still have
written records were held in 776 BCE (though it is generally
believed that the Games had been going on for many years
already). At this Olympic Games, a naked runner, Coroebus (a
cook from Elis), won the sole event at the Olympics, the stade a run of approximately 192 meters (210 yards). This made
Coroebus the very first Olympic champion in history.
The ancient Olympic Games grew and continued to be played
every four years for nearly 1200 years.

2.

Save the text as Exercise 1 and close the file.

3.

Open the document Exercise 1 and add the following paragraph
to it. Save the file and close the file.
The very first modern Olympic Games opened in the first week
of April 1896. Since the Greek government had been unable to
fund construction of a stadium, a wealthy Greek architect,
Georgios Averoff, donated one million drachmas (over
$100,000) to restore the Panathenaic Stadium, originally built
in 330 BCE, with white marble for the Olympic Games.

____________________________________________________________________________________________

1.6

Scrolling The Document

If the document is long the text can be scrolled through without
moving the insertion point. This can be easily done using the mouse.
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The scroll arrows and the scroll bar shown in figure 1.2 can be
used for this purpose. There are two sets of scroll arrows; one for up
and down movement and the other for the left and right movement of
the document.
The scrolling procedure is as follows:
1. To scroll left and right the left and right arrow respectively should
be clicked.
2. To scroll up and down the up and down arrow respectively should
be clicked.
3. To scroll a relative distance in the document the scroll box should
be drawn up or down. If there are several pages in the document
the user can know the current page number by looking at the
pop-up page number that appears next to the scroll bar.
Scrolling a document does not move the insertion point. The
mouse click should be used to get the l-beam at the required place.
______________________________________________________________
Learn by solving
Open the previously saved document Exercise 1 and see if all
the keyboard option works to move around the document. Also try
using the scroll bars and scroll arrow keys.
_______________________________________________________
1.7

Correcting Mistakes

All the characters, which are typed, appear on the screen. If a
mistake is identified it can be corrected either using the Backspace
key or the Delete key. Backspace key deletes the characters to the
left of the insertion point. Delete key deletes the characters to the right
of the insertion point.
9

1.8

Inserting Text

After the entire document is typed if the user wants to add text
in the beginning, middle or end of the document it can be easily done.
To add text the insertion point is placed where the new text is to
start and the text is typed. The new text will be inserted and the existing
text would move to the right.
The user is in the type-over mode, if the text existing to the right
of insertion point disappears, while typing a new text. The user can
toggle between type-over mode and the insert mode by using the Insert
key. The status bar gives the information about the current mode (Insert
or Type-over-mode).
As the corrections are being carried out periodically the user
should save the document using the File → Save command.
1.9

Selecting Text

Even though the document is built up by typing one character at
a time, while editing and formatting one always work with words, lines,
paragraphs and sometimes with the whole document. For this purpose
one should learn how to select the text. Once the text is selected, change
can be made to that text. The text can be moved, copied and made as
bold. The font and colour of the text can also be changed. For selecting
text the mouse or the keyboard can be used.
_____________________________________________________
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1.9.1 Selecting Text with Mouse
Following steps are to be followed:
1. Insertion point is moved to the start of the text to be selected.
2. The left mouse button should be clicked, held down and dragged
across the text to be selected.
3. When the intended text is selected, the mouse button should be
released. The text appears as shown in figure 1.5.

Fig 1.5 Selecting the Text
To unselect the wrongly selected text a click should be made
outside the selected text.

11

1.9.2 Selecting Text with Keyboard
Following are the steps to be followed:
1. Insertion point is moved to the start of the text to be selected.
2. The Shift key is pressed down and the movement keys are
used to highlight the required text.
3. When the Shift key is released, the text is selected.
1.9.3 Selection Shortcuts
The following shortcuts can also be used for selection.
Action to be performed

To select what

Double click on a word
Click once next to the line
Press Ctrl + A
1.10

To select a word
To select the particular line
To select the entire Document

Moving the Text

The selected text can be easily cut and pasted in the required
location. Following steps are to be followed.
1. The text to be moved to a new location is selected.
2. Edit → Cut is selected or in the tool bar is selected to cut
the selected text.
3. Insertion point is moved to the place where the text is to be
pasted.
in the tool bar is selected to
4. Edit → Paste is selected or
paste the text in the new location. The text can also be pasted in
this way to another or another type of document.
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The following keyboard shortcuts can be used to move text.
Ctrl + X → to Cut
Ctrl + V → to Paste
1.11

Copying the Text

1. The text to be copied is selected.
2. Edit → Copy is selected or

is clicked.

3. The insertion point is selected where the copy of the text should
appear and is
clicked.
The following keyboard shortcuts can also be used for copy and paste:
Ctrl + C → to Copy
Ctrl + V → to Paste
1.12

Finding and Replacing Text

You can use the Find & Replace feature in StarOffice Writer to
search for and to replace words in a text document.
To Find and Replace Text
1. Choose Edit → Find & Replace.
The Find & Replace dialog box appears as shown in the
Fig 1.6.
2. In the Search for box, type the text that you want to find in your
document.
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Fig 1.6 Find and Replace Dialog Box
3. In the Replace with box, enter the replacement word or phrase.
4. Click Find to start the search.
5. When Writer finds the first instance of the word or phrase, do
one of the following:
•

To replace the found instance of the text with what you
entered in the Replace with box, click Replace.

•

To replace all instances of the text with what you entered in
the Replace with box, click Replace All.

•

To skip the found text and to continue the search, click Find
again.

6. Click Close when you have finished the search.
Note: You can also select the word or phrase that you want to search
for in the text document, and then choose Edit - Find & Replace. The
text that you selected is automatically entered in the Search for box.
_____________________________________________________
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Learn by solving
1. In the StarOffice Writer document Exercise 1 try to add additional
text both at the beginning, middle and end of the document.
2. Make use of the Delete key Backspace key for making
correction.
3. Make use of the Insert key to insert a new word and see how the
Insert mode changes in the Status bar.
4. Select a particular portion of the document using selection
shortcuts, cursor and with the keyboard.
5. Perform the Copy, Cut and Paste operations using the icons as
well as the keyboard shortcuts.
6. Make use of the Find and Replace a given word and see how it
works.
Summary
•

Entering a new text or modifying the existing text in a document
is known as text editing.

•

The user can move to the various portions of the document using
the keyboard shortcuts or the mouse.

•

The required word or portion of the text can also be selected
using the keyboard shortcuts or using the mouse.

•

Copy, Cut, Paste, Find and Replace are some of the commonly
used editing functions.
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Exercises

I. Fill in the blanks.
1. The thick horizontal line in the page area is called _____,____
2. ___ key deletes the characters to the right of the insertion point.
3. _____, ______ option is selected to Cut the selected text.
4. ________ and __________ are the two combo boxes available
in the Find and Replace dialog box.
5. ___ key combination is used to move to the end of the document.
II.

State true or false
1. Enter key must be pressed at the end of each line.
2. To select the entire document pressing Ctrl + A is the hot key
combination to be used.
3. For searching a given word one need not have to type the
required word in the Find and Replace dialog box.
4. To paste the selected word in the desired place insert key is
used.
5. Ctrl + X is the keyboard shortcut for copying the selected text.

III.

Answer the following
1. What is meant by text editing?
2. How would you select the required portion of the text in a
document?
3. How would you switch over form Insert mode to Type-over mode?
4. What are the steps to be followed for searching a given word?
5. Give the steps involved for replacing a given text.
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