CHAPTER 2
TEXT FORMATTING
A text without any special formatting can have a monotonous
appearance. To outline text, to highlight individual words, quotations,
or references, or to separate certain parts of the text, various types of
formatting can be applied.
2.1

Formatting Options

StarOffice Writer offers a number of choices for formatting such
as bold or italics, and defining the font, type, and font size. Bold, italic
or underlined are the most common types of text formatting.
Almost all the formatting options are available under Format
menu. StarOffice Writer also conveniently provides buttons for the most
commonly used options. But before these options can be used, the
text on which they are to be used has to be selected. Once the desired
portion of the text is selected then depending on the need any one of
the following buttons are clicked:
Click
Click
Click

to make text Bold.
to make text Italic.
to make text Underlined.

The same can also be achieved by clicking on Format →
Character and then selecting an option from the Typeface list box.
If a particular word or portion of the text is already in bold or
italic or underlined style those text properties can be removed by
clicking on the respective icons, again.
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For example, in order to change the word Computer from bold
to normal appearance that word is selected and the icon
is pressed
once. This will remove the bold property from that text.
Alternatively Ctrl + B, Ctrl + I and Ctrl + U keys can be used to make
the selected text bold, italic and underlined respectively.
2.1.1 Changing the Fonts
A font is a set of characters and numbers in a certain style. Each
font looks different from other fonts. Some fonts, like the Times New
Roman, look professional and are suited for business documents.
Some fonts, like FAJITA, are decorative. Some fonts, like Symbol
and Wingdings, are actually sets of symbols. Such a font can be used
to insert special characters in the document.
Part of word processing skill is choosing an appropriate font
for the document. Text can be selected and any of the fonts available
in the system can be used. Font packages can also purchased to add
other font choices to the system.
Method
Click the down arrow in the Fonts Combo box of font tab in
Character dialog box.
Use Format  Character to open the Character dialog box.
From the list of available fonts, click the required one.
The text changes to the selected font.
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2.1.2 Font Size
The size of the text is also important. The same size of the text
cannot be used for a legal document, and an advertisement material.
Similarly the size of the letters used in the main text and footer cannot
be the same. The size of a font is measured in points, and there are
72 points to an inch. The larger the point size, the larger the type.
Method
Click the down arrow in the Size combo box of Fonts tab in
Character dialog box.
Use Format  Character to open the Character dialog box.
The text changes to the selected font size.

2.1.3 Changing the Font Colour
A different colour for selected text can be used. Colour printers
are becoming more and more popular. With the help of a colour printer,
some splash can be added to the documents by changing the colour
of text. In the absence of a colour printer, the document will be displayed
on screen in colour. But these changes will be printed as shades of
gray on a black-and-white printer.
Method
To use a different text color, select the text and click the arrow in
the Font Colour icon. A colour palette is displayed from which
the required colour can be selected.
Alternatively, select the text and click on the Font colour icon,
to apply the current colour of the Font Colour.
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2.1.4 Highlighting the Text
Highlighting can be used to call attention to key ideas or pointers
in a document. When reading something important in a book, a
magazine, a report, or any document, the reader takes a yellow
highlighter pen and drags across it. These highlighted sections are
used to review or find the key points in the document. The same thing
can be done in the StarOffice Writer document. The colour to be used
for highlighting can also be selected.
Method
is
To highlight the selected text, the Highlighting icon
selected, and then the needed colour is clicked. StarOffice Writer now
applies the highlighting. When the mouse button is clicked on the above
icon and held down a colour palette is displayed from which the required
colour can be selected. To remove the highlighting, select the text and
select the No Fill from the colour palette.
As mentioned earlier, the Character option under the Format
menu can also be used to achieve all this. Clicking on Format
→Character displays the Character dialog box as shown in the
following figure. This method is used to make several changes at once
or to preview the changes before applying them.

Fig 2.1 Character Dialog Box
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______________________________________________________________________________________________________________________________________________

Learn by solving
Select a particular portion in the document Exercise 1 and perform the
following tasks:
•
•

Change the text properties (normal to bold, then to italic and
underlined). Finally bring it to normal type.
Change the font, font size, colour and observe the changes.

________________________________________________________________________________________

2.2

Paragraph Alignment

In addition to formatting individual chunks of text, one can also
format the paragraphs. One of the most common changes is to change
the alignment of a paragraph.
A paragraph is any text followed by a hard return. (A hard return
is inserted every time when Enter is pressed. Soft returns are inserted
as line breaks by StarOffice Writer and are adjusted when text is added
or deleted.) A single line, for instance, can be a paragraph. One can
apply the paragraph formatting options to a single paragraph or to
several paragraphs. Each paragraph, for example, can give different
tab settings.
Also, each time Enter is pressed, the paragraph options for
that paragraph are carried down to the next paragraph. And if a
paragraph marker is deleted the paragraph takes on the formatting of
the following paragraph. If one types a line, center it, and press Enter,
the next line is centered as well. If a double-spaced paragraph is
followed by a single-spaced paragraph, delete the paragraph mark at
the end of the first paragraph, the paragraph will then be single-spaced.
This is confusing for beginners who wonder how a paragraph got
formatted without anyone making a change. One can think of the
paragraph marker as the storehouse for all formatting options for that
paragraph.
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When typing in StarOffice Writer, all text is left aligned, and the
right margin is ragged or uneven. For most text, this alignment works
great. For other paragraphs, one may want to make a change. For
instance, one can center the document title or right align text like a
newspaper banner. The text in the paragraphs can be justified to keep
both margins even.
Four types of alignment can be selected, and the best way to
make a change is to use the Formatting toolbar. Following steps are
used:
1. To change the alignment of one paragraph, first click within that
paragraph. To change the alignment of several paragraphs,
select the ones needing change.
2. Do one of the following
Click

to left align text.

Click

to right align text

Click

to justify text.

Click

to center text.

Figure 2.2 shows an example of each type of alignment.
To undo the change, click the Undo button or select the Edit →
Undo command. If a different alignment is required later, select the
paragraph (s) and then click another alignment button.
To undo the change, click the Undo button or select the Edit →
Undo command. If a different alignment is required later, select the
paragraph (s) and then click another alignment button.
To undo the change, click the Undo button or select the Edit → Undo
command. If a different alignment is required later, select the
paragraph (s) and then click another alignment button.
To undo the change, click the Undo button or select the Edit →
Undo command. If a different alignment is required later, select the
paragraph (s) and then click another alignment button.
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The following keyboard shortcuts can also be used to change
the alignment.
To make text...
Centered
Left-aligned
Right-aligned
Justified

Press...
Ctrl+E
Ctrl+L
Ctrl+R
Ctrl+J

_____________________________________________________
Learn by solving
Open the document Exercise 1. Carry out the following
instructions and observe the changes.
1.
2.
3.
4.

Add a suitable heading at the top and center it.
Select the second paragraph and use justify it.
Select the third paragraph and right align it.
Add your name, class and school’s name at the bottom and
right align it.
5. Add the date at the bottom in the line below the title and right
align it.
_____________________________________________________
2.3

Indenting Text

Alignment changes are most appropriate for headings or other
special paragraphs in the document. But to make a long document
easy and inviting to read, some of the paragraph-formatting features
described in this section, including indents can be used. For instance,
indent the first line of each paragraph. This visual clue helps the reader
to see how the document is divided into paragraphs. The paragraphs
also indented , such as quotations that are set apart from the main
document text. As another option, one may want to use a special kind
of indent, called a hanging indent, for numbered lists.
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The amount of indent can be varied to the requirement, and one
can use either the Formatting toolbar or the Paragraph dialog box to
make a change, as covered in this section.
2.3.1 Indenting Text with the Toolbar
If a left indent is required - useful for setting off a paragraph
from the main body text - the toolbar can be used to set the indent.
Click the Increase Indent
icon; the paragraph is indented 1/2 inch
from the left margin. The button again can be clicked to increase the
indent. Each time the button is clicked, the paragraph is indented
another 1/2 inch.
Figure 2.3 displays a paragraph that has been indented using
the Increase indent button.

Fig 2.3 Paragraph indented using the Increase Indent icon
If the indent is too much or if one wants to undo the indent, the
Decrease Indent
icon is clicked to decrease of undo the indents.
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2.3.2 Indenting Text with the Paragraph Dialog Box
The Increase Indent and Decrease Indent icons are useful if it is
needed to indent text from the left. If one wants to indent from the left
and right or if one wants to create a special kind of indent, a different
method is used. The Paragraph dialog box must be used.
Following steps are used to indent text using the Paragraph dialog box:
1. Move the insertion point to the beginning of the paragraph to be
indented. To indent several paragraphs, select those
paragraphs.
2. Select Format → Paragraph command.
3. Click the Indents & Spacing tab in the Paragraph dialog box
as shown in figure 2.4.
4. Do any of the following.
i.

To indent from the left, type the amount to be indented in the
Before text spin box or use the spin arrows to select a value.

ii. To indent text from the right, type the amount or use the After
text spin arrows to enter the amount in the spin box.
iii. Click the OK button.
The First line option can be used to indent the line of the
paragraph. Using the spin arrows, if a positive value is specified, the
first line will be indented. A negative value will result in a hanging indent;
that is, the first line will hang outside the paragraph.
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Fig 2.4 Indents and Spacing Dialog Box
_____________________________________________________
Learn by solving
Reproduce the following paragraphs as such using both, the toolbar
icons and the menu options.
A table is a collection of rows that are related to each other by a common
idea, such as customer table, which contains all the information about
the customers.
Structured Query Language is the special language used to access
the data contained in a database.
_____________________________________________________
2.4

Modifying Line Spacing

By default, StarOffice Writer single-spaces
the text in the document. This spacing works well
for short documents such as letters and memos,
but in longer documents, such as a manuscript,
one may want to use a different spacing values.
Single line, 1.5 lines, Double, Proportional, At
least, Leading and Fixed are the line spacing
options available as shown in figure 2.5.
Fig 2.5 Line spacing Options
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To change the line spacing, following steps are used:
1. Select the paragraphs(s) that needs to be changed.
2. Select Format → Paragraph.
3. If necessary, click the Indents & Spacing tab. The Indents &
Spacing tab dialog box as shown in figure 2.4.
4. Click on the Line spacing drop-down list box, and select the
required line spacing option.
5. Click the OK button.
________________________________________________________________
Learn by solving
Open the document Exercise 1. Change the line spacing into
1.5 line spacing and double line spacing and observe the change.
_______________________________________________________________________
2.5
Creating Bullets and Numbered List
When the document presents a matter using text in the form of
long paragraphs the reader may not be able to quickly notice the
important points or messages. For this purpose bullets and numbers
are used to list the important points and messages.
One way to set off a list of points or topics in a document is to
create a bulleted list. A bullet precedes each item in the list, and the
text is indented. One can also create a numbered list. Numbered lists
work well for directions or other points one want to present in sequence.
StarOffice Writer automatically numbers all the items in a list, and the
text is indented.
2.5.1 Creating a Bulleted List
The fastest way to create a bulleted list is to be use the Bullets
button on the Formatting toolbar. For this purpose the following steps
are used:
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1. Select the text that to which bullets are to be added. The
StarOffice Writer will add bullets to each paragraph within the
selection, and not to each line. StarOffice Writer will add bullets
to any blank lines within the selection.
2. Click on the Bullets icon
from the formatting tool bar,
StarOffice Writer creates a bulleted list, as shown in figure 2.6.

Fig 2.6 Bulleted List
2.5.2 Creating a Numbered List
For items that appear in a specific order, such as a series of
steps, one can create a numbered list. StarOffice Writer will add the
numbers automatically and also indent the paragraphs so that the text
is aligned properly. All one has to do is click the Numbering icon
.
Another great thing about a numbered list is that if one adds or
deletes an item within the list, StarOffice Writer renumbers the list.
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Following steps are used to create a numbered list.
1. Select the text to be numbered. The StarOffice Writer will number
each paragraph. Blank lines within the selection will be
numbered.
2. Click

icon to create a numbered list.

2.5.3 Removing the Bullets or Numbers
To remove bullets from a list, the list is selected and the Bullets
button is clicked again. To remove numbers for a list, select the list
and click the Numbering button.
2.5.4 Applying Different Styles for Bullets and Numbers
StarOffice Writer provides various styles for the bullets and
numbers, which can be selected using Format → Bullets and
Numbering.
Bullets and Numbering dialog box appears as shown in the
figure 2.7a and 2.7b.

Fig 2.7a Bullets and Numbering dialog box with the
Numbering Style tab selected
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Fig 2.7b Bullets and Numbering dialog box with the
Bullets tab selected.
Using the various options available for bullets and numbers the
user can select the desired one.
_____________________________________________________
Learn by solving
1. Create a list of your favorite games. Number them using the
Numbering tool. Modify the list and add two more game.
Change the numbers to bullets.
2. Type a list of ten of your friends. Format them using the bullets
option. Change the bullet and observe the result.
_____________________________________________________
2.6

Formatting Using Styles

This is an alternative way of formatting text. A style is a named
set of defaults for formatting text. The formatting methods discussed
earlier are more appropriate for one time use. If, for example, a word
is to be made as bold, just the cursor is positioned in the word and the
Bold icon is clicked. This works quickly and intuitively.
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But if several documents, each running into several pages are
to be formatted in a particular style, then a style is more useful. This
type of formatting is also easier when a format has to be used at several
points within the text. Styles require more advanced planning. The
style needs to be created initially only then the style can be applied to
the text, using the Typeface list. The advantages of working with styles
can really be appreciated when making extensive formatting changes.
2.7

StarOffice Help

StarOffice 8 provides several help systems that you can use while you work:
•
•
•
•

Online help
Help Agent
Help Tips
Extended Help Tips

Fig 2.8 StarOffice Writer Help
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The Choose help file box in the toolbar area at the top of the
Help window can be used to search for help on other StarOffice
elements. This is a list box with the list items shown in figure 2.9

Fig 2.9 Choose Help file list box
You can access the StarOffice Help in several ways:
•

Choose the menu command Help - StarOffice Help, or press
F1. This command opens the StarOffice help where you can
search for a help topic.

•

Click the Help button in any dialog to open the help topic for the
dialog.

•

Click the Help Agent that appears automatically when you
perform a complex task. The Help Agent opens the help topic
for the task.

•

Rest the mouse pointer over a menu command or over any icon
to display a Help Tip.

•

To view a brief description of what the command or icon does,
press Shift+F1 to display an Extended Tip.

•

The Help Agent is displayed on the screen in a small window as
shown in figure 2.10.

Fig 2.10 The Help Agent Window
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The content of Help Agent window changes depending on what
is being done in the main window. For example, if some text is
highlighted and the Bold icon is clicked the Help Agent displays help
about the Bold formatting option as shown in figure 2.11.

Fig 2.11 Help Agent window with help about Bold formatting.
Summary
•

There are two types of formatting (i.e.) hard formatting and soft
formatting.

•

Changing the text style-bold, italic, underlined, and the font
properties - size, colour are the commonly used formatting
changes.

•

Paragraph alignment can be of the following four types
1.
2.
3.
4.

Left alignment
Right alignment
Justification
Centering
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•
•
•
•

•

Indentation helps in providing the document more readability.
The spacing between the lines in a StarOffice Writer document
can easily be changed.
Bullets and Numbers are used to list the important points and
messages.
An alternate method of formatting refers to creating a particular
style and applying it quickly to a document instead of making
individual changes to the line spacing, paragraph alignment,
indentation etc.
StarOffice has an on-line help facility. This facility can be used
by clicking on the Help menu.

Exercises
I. Fill in the Blanks
1. The size of a font is measured in ____________ and there are
__________ points to an inch.
2. The ___________ printer is required to get the hard copy of
the document in colour.
3. __________feature is used to mark the important portions of
the document.
4. _____________ key combination is used for justifying the
selected paragraph.
5. The ___________ is a named set of defaults for formatting text.
II. State true or false
1. Line spacing should always be an integer value.
2. Indenting text helps to increase the readability.
3. Modifying the line spacing will also modify the spacing between
words in a line.
4. To remove bullets from a list the list is selected and the delete
button is clicked.
5. A font is a set of characters and numbers in a certain style.
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III. Answer the following
1. What is the difference between hard formatting and soft
formatting?
2. What are the formatting changes that can be made with respect
to the fonts?
3. What are the various types of paragraph alignments that can
be made?
4. What does indenting the next mean?
5. How would you create the bullets and numbered list?
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